
Overview: Finding Images

You can use HiJaak Catalog Find to locate graphics scattered across your system or network. Using its 
flexible search capabilities, you can search on attributes common to all files, such as location, whole or 
partial file name, date, and size; and you can also search on attributes specific to graphics files, such as 
number of colors, class, height, width, grayscale, and custom attributes. You can also use keywords that 
are automatically extracted from your vector files or manually added to the Properties sheet as criteria on
which to find a file. 

Once HiJaak 98 finds the files that meet the criteria you specified, it displays these files in a search 
results window. In this search results window, you can perform many file operations such as drag and 
drop, move, copy, import, create shortcuts, and open. You can also save the search criteria or the search 
criteria and results.    

{button ,AL(`prohowto find',1,`',`')} How To...
{button ,AL(`formats;keywords;update;catalogs;properties;filefound')} Related Topics



To find an image
1. To run HiJaak Catalog Find, click here ; or click the Start menu and point to Find. In the Find 

subfolder, click HiJaak Catalog. 
The HiJaak Catalog Find dialog box displays.

2. There are 7 search criteria tabs from which to choose. You can specify criteria in any or all of the tabs. 
Click the tabs containing the criteria on which you want to search and fill in the information on each. 
For information on any of the available criteria, right-click the option and click What’s This?.

3. Click Find Now. HiJaak 98 searches the catalog for all graphics files meeting the criteria you specified,
then displays the results in a search results window.
You can perform any file operations on the files found. 
To save the search, pull down the File menu and click Save Search. HiJaak Find places a shortcut 
called SEARCHN.HJF on your desktop, where N  is the number of your last search.
To save the search and its results, pull down the File menu and click Save Results; then, pull down 
the File menu and click Save Search.
To find other files, click the New Search button and repeat the above procedure.
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Working with the Files that HiJaak Finds

Using HiJaak Catalog Find to locate your graphics files is useful because it finds files quickly and 
accurately, and it allows you to perform many operations on the files found. 

You can also modify the display of the search results window to make it easier to find a particular file. You 
can then move, copy, delete, import or open any file located in the search results window. If you want, you
can save the search criteria and/or the search results. 
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To save a search
 Run the search you want to save. Pull down the File menu and click Save Search (Alt+f, s). HiJaak 
places a shortcut to the saved search on your desktop. The first search you save is named 
SEARCH1.HJF, and is incremented with each additional saved search. The file is located in your 
WIN95\DESKTOP folder.
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To save search results
 Run the search you want to save. Pull down the File menu and click Save Results (Alt+f, s). Pull down 
the File menu and click Save Search (Alt+f, s). HiJaak places a shortcut to the saved search on your 
desktop. When you open this shortcut, the results from the search will appear in the window. They will 
be updated the next time you select the Find Now button.
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To rename a saved search
1. Click the secondary mouse button on the icon representing the saved search on your desktop. You will 

see the shortcut menu.
2. Click Rename. The file name beneath the icon becomes framed and highlighted.
3. Type the new name with an HJF extension and press Enter. 



To modify the view of the search results window
Pull down the View menu and click one of the following:
Large Icons--displays large thumbnails and file name 
Small Icons--displays small thumbnails and file name 
List--displays small thumbnails in a list and file name 
Details--displays small thumbnails, file name, folder, type, size and date (Alt+v, d)

 To sort alphabetically by name, pull down the View menu and click Arrange Icons, then select 
by Name; or, click the Name button in the search results window (Alt+v, i, n.

 To sort alphabetically by the containing folder, pull down the View menu and click Arrange 
Icons, then select by Folder; or, click the Folder button in the search results window (Alt+v, i, 
f).

 To sort by size from smallest to largest, pull down the View menu and click Arrange Icons, then
select by Size; or, click the Size button in the search results window (Alt+v, i, z).

 To sort alphabetically by type, pull down the View menu and click Arrange Icons, then select by
Type; or, click the Type button in the search results window (Alt+v, i, t).

 To sort by the date modified from oldest to newest, pull down the View menu and click Arrange 
Icons, then select by Date; or, click the Modified button in the search results window (Alt+v, i, 
d).



To create a shortcut to the files found
1. In the search results window, click the file or press CTRL and click the files to which you want to create 

shortcuts.
2. Right-click any of the selected files and drag to the desktop or folder where you want to place a 

shortcut to the file or files. The drag and drop menu displays.
3. Click Create Shortcut Here.



To copy files from the search results window
1. In the search results window, click the file or press CTRL and click the multiple files you want to copy.
2. Right-click any of the selected files and drag to the desktop or folder where you want to copy the files. 

The drag and drop menu displays.
3. Click Copy Here. 



To move files from the search results window
1. In the search results window, click the file or press CTRL and click the multiple files you want to move.
2. Right-click any of the selected files and drag to the desktop or folder where you want to move the files. 

The drag and drop menu displays.
3. Click Move Here. 



To import the files that HiJaak finds into another document
1. Open the OLE 2.0 container application and the document into which you want to import the file. Make 

sure both the HiJaak Find and the application windows are visible on the screen.
2. In the search results window, click the file you want to import and drag it onto the open application 

window into which you want to import the files. (Do not drag onto the icon in the taskbar.) 
HiJaak embeds the file in the open document. 



To view/open a file from the search results window
 In the search results window, click the file you want to open . Pull down the File menu and click Open 
(Alt+f, o). 

OR:
 In the search results window, double-click the file that you want to open. 

HiJaak 98 launches the application with which the file is associated and that application opens the file.



To open the folder that contains a file found
1. Click the file in the search results window whose containing folder you want to open. Note that you 

cannot use this command with multiple files.
2. Pull down the File menu and click Open Containing Folder. HiJaak 98 opens the folder in which the 

original file is located.



To select all files in the search results window
 Pull down the Edit menu and click Select All (Alt+e, a).



To invert the selection of files in the search results window
 Pull down the Edit menu and click Invert Selection (Alt+e, i). 



Find Dialog Box

Provides a place for you to search for graphics files. Each tab represents a different search criterion. You 
can search on one or all of the available criteria. Once you have specified all the criteria on which you 
want to search, the Find Now button runs the search. The Find dialog box then expands to display the 
files that meet the criteria you specified.
{button ,AL(`prohowto find',1,`',`')} How To...



Name and Location

Searches for files based on a whole or partial file name or location. If you want, you can instruct HiJaak 
98 to search all subfolders of the selected path as well. It is recommended that you specify a location in 
which you want HiJaak 98 to search for files. By specifying a location, you greatly narrow the search and 
decrease the time it takes to complete it. 
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Named
Provides a place for you to type all or part of the name of the file you are searching for.    
Type as much of the file name as you know into the File Name box (Alt+n). You can use the DOS 
wildcards * and ? to replace the part of the file name you do not know. 



Look In
Provides a place for you to type the drive and folder in which to look for the file.
To search a specific location, click in the Look In box and type the full path where you want to search 
(Alt+l).



Browse
Displays the Browse dialog box in which you can browse for the folder in which you want to search.



Include Subfolders
Searches all subfolders of the selected folder in the Look In box. 



Files in Disconnected Drives or Folders
Finds only files that are located on drives or in folders that are disconnected from your computer at the 
time the search is run. These files may be located on a CD-ROM that is not currently in the drive, or on a 
network drive to which you do not have access, but because they are located in the HiJaak Catalog, 
HiJaak 98 can still find them.
If this check box is cleared, HiJaak will find only files that are accessible to you at the time the search is 
run.



Keywords

Provides a place for you to type keywords on which to search for files. HiJaak 98 searches through both 
automatically extracted keywords and keywords that were manually added to files using the Properties 
sheets. HiJaak 98 searches for files that contain every keyword you specify, regardless of their position or
proximity in the Properties sheet's Keywords box. 

You can also use wildcards in the Keywords search box to narrow the search further. Use any of the 
following wildcards:

* finds any number of characters
? finds any character
[xxxyyy] finds any character within the braces
@xxxyyy@ finds exact text phrase contained within the @ signs
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Keywords
Provides a place for you to type keywords on which to search. Keywords are either automatically 
extracted from the file during updating or manually defined in the Properties dialog box.
To search for files with certain keywords, click in the Keyword box and type the keywords (Alt+k). 
To use wildcards, substitute any of the following: *    finds any number of characters; ?    finds any 
character; [xxxyyy]    finds any character within the braces; @xxxyyy@    finds exact text phrase 
contained within the @ signs.



 Size and Date

Searches for files based on a range of file sizes and/or a range of dates on which to search. The dates 
represent the time at which the file was last modified. When you specify a size, you should also specify 
the units of measurement you want to use: bytes, kilobytes or megabytes. 
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Size
Contains controls that allow you to specify criteria to find files based on file size.



Units
Specifies the unit of measure for file size used when entering a number in the From and To boxes in the 
Size area.
Click Megabytes, Kilobytes or Bytes.



Size: At Least ... At Most
Provides a place for you to type a range of file sizes on which to search.
To search for files that are a specific size, click in the At Least box and type that size. Then, click in the 
At Most box and type that same size (Alt+s, Tab).
To search for files that fit into a range of sizes, click in the At Least box and type the smallest size for 
which you want to search. Then, click in the At Most box and type the largest size for which you want to 
search (Alt+s, Tab). 



Date
Contains controls that allow you to specify criteria to find files based on the modification date.



Format
Displays the format in which you should enter the date on which you want to search. The date format is 
controlled by Windows Control Panel Regional Settings.



Date: From ... Until
Provides a place for you to type a range of modified dates on which to search.
To search for files that were modified during a range of dates, click in the From and type the earliest date 
for which you want to search. Then, click in the Until box and type the latest date for which you want to 
search (Alt+d, Tab). 
To search for files that were modified on a specific date, type the same date in both boxes.



Image Attributes

Searches on any of the following attributes: number of pages in a file, a file's type based on format 
extension, number of colors, grayscale, fonts, or a file's image class: raster, vector, metafile, or 3D.
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Image Class
Specifies the class of the file for which you want to search: Raster, Vector, Metafile, or 3D.



Type
Specifies the type of the file based on file extension for which you want to search. You can search on any 
file type supported by HiJaak 98.



Fonts
Searches for files containing text in a specific font. You can search on any TrueType font registered with 
Windows.
This option will locate only vector or metafile images. Raster images don’t contain font information.



Number of Pages
Specifies the number of pages in the file for which you want to search.
To search for files that have a range of pages, click in the At Least box and type the least number of 
pages for which you want to search. Then, click in the At Most box and type the largest number of pages 
for which you want to search (Alt+p, Tab). 
If you know the exact number of pages, type the same value in both boxes.



Number of Colors
Specifies the number of colors in the file for which you want to search.
To search for files that have a range of colors, click in the At Least box and type the lowest number of 
colors for which you want to search. Then, click in the At Most box and type the largest number of colors 
for which you want to search (Alt+c, Tab). 
To search for files that are a specific number of colors, type the same value in both boxes.



Grayscale
Finds files that are composed of shades of gray ranging from black to white.



Image Size

Searches for files based on their width and/or their height. Before you set the Width and Height options, 
you should specify the unit of measure you want to use: Inches, Centimeters, Pixels or Picas.
The criteria in this dialog box is useful primarily for finding raster files. You can click the Image Attributes 
tab and select Raster in the Image Class area to narrow the search. However, some vector files, such as
PCT, also contain sizing information; so the criteria in this tab can be used to locate those files as well. 
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Units
Specifies the unit of measure used when entering a number in the Width and Height boxes.



Width
Contains controls that allow you to specify criteria to find files based on an image's width.



Width: At Least ... At Most
Provides a place for you to type a range of widths on which to search.
To search for files that fit into a range of widths, click in the At Least box and type the smallest width for 
which you want to search. Then, click in the At Most box and type the largest width for which you want to 
search (Alt+w, Tab). 
To search for files that are a specific width, type the same value in both boxes.



Height
Contains controls that allow you to specify criteria to find files based on an image's height.



Height: At Least ... At Most
Provides a place for you to type a range of heights on which to search.
To search for files that fit into a range of heights, click in the At Least box and type the smallest height for 
which you want to search. Then, click in the At Most box and type the largest height for which you want 
to search (Alt+h, Tab). 
To search for files that are a specific height, type the same value in both boxes.



Catalogs
Specifies which catalogs to search through.
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Known Catalogs
Lists all catalogs available to HiJaak for searching. Click those catalogs that you want HiJaak 98 to 
search for files. 



Search Current Catalog Only
Searches only the catalog that you have open when performing the search. When this check box is 
selected, all catalogs except the current will be deselected in the Known Catalogs list.



Add
Displays the Find Catalogs dialog box which allows you to add catalogs to the Known Catalogs list.



Select All
Selects all catalogs in the Known Catalogs list. HiJaak will search every catalog available for files meeting
the criteria you specify.



Deselect All
Deselects all catalogs in the Known Catalogs list. You must select one catalog before switching out of this
tab.



User Attributes

Searches for custom attributes that you have defined in HiJaak Catalog Setup and attached to files 
through their Properties sheets. You can search on as many custom attributes as you want by building a 
list in the Search Attributes area of this tab. Only files meeting all attributes you add to this list will be 
found.
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Attribute Name
Specifies the name of the attribute you will be searching for.



Relationship
Indicates the relationship between the Attribute Name and Attribute Value: Equal to, Greater than or Less 
than. Which of these options are available depend on the type of attribute you have selected in the 
Attribute Name box.



Attribute Value
Specifies the value of the named attribute.



Search Attributes
Lists those search expressions ATTRIBUTE NAME = VALUE HiJaak will search for. HiJaak will only 
search for custom attributes in this list. Each expression is connected with an “AND”.
You can add expressions to this list using the Add button.



Add
Adds the full search expression ATTRIBUTE NAME=VALUE to the Search Attributes list.



Delete
Removes the selected search expression from the Search Attributes list.



Find Now
Begins the search.



Stop
Terminates a search in progress.



New Search
Clears the criteria of the previous search, allowing you to enter new criteria on which to search.



Name
Sorts files found alphabetically by file name.



Folder
Sorts files found alphabetically by the containing folder.



Size
Sorts files found by size from smallest to largest,



Type
Sorts files found alphabetically by type



Modified
Sorts by the date modified from oldest to newest.






